Wednesday, 25 November 2009

SharePoint Designer 2007/2010 and x86/x64

Just fell foul of not reading the documentation. DOH!

 

This is important information for anyone who needs their laptop/client PC to work with both SharePoint 2007 AND 2010.

 

On the SPD 2010 download page it does clearly state:

 

SharePoint Designer 2010 only connects to SharePoint 2010. To connect to SharePoint 2007 and earlier sites you must continue to use SPD 2007 . If you elect to install both applications side-by-side, you must download the 32-bit version of SPD 2010. Please also note that 64 bit Office applications will not run if SPD 2007 is installed; 64bit Office 2010 applications should only be used if not connecting to SharePoint 2007 servers.

 

So… If, like me, you need to work with both 2007 and 2010 then you need:

 

> SharePoint Designer 2007

> SharePoint Designer 2010 Beta 2 32bit

> Office 2010 beta 2 32bit (or Office 2007, I suppose…)

Note to self: RTFM!

No comments:

Post a Comment

Please feel free to comment on this post, I want to hear your feedback!